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ClearID 2.6.4.1 b051215 Release Notes  
 

 

Version ClearID 2.6.4.1 ClearID 2.6.3a ClearID 2.6.3 

Release Date 05/12/2015 02/27/2015 07/08/2014 

Support Date* 04/01/2010 04/01/2010 04/01/2010 

*Free upgrade to customers that are in support as of this date. 
 

This is likely the last release of 32-bit versions of ClearID.  ClearID 3.0 64-bit is will be released shortly.  
Get in support to receive your free upgrade. 

 

ClearID 2.6.4.1 Bug Fixes and New Features - Released: 05/12/2015 

- Import Images as Layer Stack improved by adding browse directly to image with file preview without the need to 
use Adobe Bridge. Located under PS > File > Scripts > Import Images as Layer Stack. 

 
Because of changes in Photoshop and Bridge interconnectivity in CC 2014, you could no longer import a bridge 
selection between the two programs.  This affected the ClearID Import Images as a Layer Stack function so it has 

been updated.  Now instead of importing a Bridge selection, you don’t even need to use Bridge. Simply launch 

Photoshop and go to PS File > Scripts > CID Import Images as Layer Stack and browse to the images you 

want to import. Select the “Select Individual Files” option then click “Browse”. This will allow you to browse to a 

specific folder were you can preview thumbnail of the images before deciding which images you want to select.  
Use standard Windows conventions for selecting images… hold SHIFT to select a range and hold CTRL to add or 

remove an image from your selection. 
 
Using this method for importing images as a Layer Stack will also hash each image in the PS layer.   

 

 

- Bug Fix. Align and Average Layers was grayed out in PS CC 2014 32 bit.  This issue has been resolved.  
Support for this feature was also extended to CC 2015 

- Bug Fix: PS Reduce Noise - unexpected java script error corrected 

http://www.oceansystems.com/forensic/forensic_video_analysis/omnivore/omnivore-quote.php


ClearID 2.6.3 & 2.6.3a 
Release Notes 

1 2/27/2015   

ClearID 2.6.3a/2.6.3 Release Notes  
 

 

Version ClearID 2.6.3a ClearID 2.6.3 ClearID 2.6.2 

Release Date 02/27/2015 07/08/2014 09/28/2012 

Support Date* 04/01/2010 04/01/2010 04/01/2010 

 
     *Free upgrade to customers that are in support as of this date. 
 
ClearID 2.6.3a Updated Installer Support - Released: 02/27/2015 

- Provided installer support for:  

Photoshop CC 2014 (32-bit mode only) 
Photoshop CC 2015 (32-bit mode only) 

 
ClearID 2.6.3 Updated Installer Support - Released: 07/08/2014 

- Provided installer support for:  

Photoshop CC (32-bit mode only)
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ClearID 2.6.2 Release Notes  
 

Version ClearID 2.6.2 ClearID 2.6.1 ClearID 2.5 

Release Date 09/28/2012 05/29/2012 09/28/2012 

Support Date* 04/01/2010 04/01/2010 04/01/2010 

  
    *Free upgrade to customers that are in support as of this date. 

 
ClearID 2.6.2 Bug Fixes and New Features - Released: 09/28/2012 

- Tab 2: Frame Averaging. With the release of Adobe Photoshop CS6 and CID 2.6.1 for CS6, frame 
averaging was not working. This has been fixed. 

- File > Scripts > ClearID – Import images as Layer Stack from Bridge selection now works with CS6. 

- Verification Report updated. Previously there was one header named “Document Info” that listed both 
your current open Photoshop Document and info about what software was loaded on the system when the 
“Verification Report” was generated.  
 
This information is now separated into two groups. The software and system information has been moved 
under a new header called “System Info”. 

 

 

 

Revised ClearID 2.6.2 Verification Report 
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ClearID 2.6.1 Release Notes   
 

 

Version ClearID 2.6.1 ClearID 2.5 ClearID 2.0.2 

Release Date 05/29/2012 09/14/2010 06/03/2010 

Support Date* 04/01/2010 04/01/2010 -- 

  
    *Free upgrade to customers that are in support as of this date. 

 

ClearID 2.6.1 Updated Features - Release Date: 05/29/2012 

- Compatible with Adobe Photoshop CS6 in 32bit mode 

- New registration/unlock code screen and new online unlock code request processing 

- Fixed Microsoft Share Point conflict with Interactive Deblur 
 

 

 

New ClearID Registration/Unlock Screen 
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ClearID 2.5 Release Notes  
 

 

Version ClearID 2.5 ClearID 2.0.2 

Release Date 09/14/2010 06/03/2010 

Support Date* 04/01/2010 -- 

     
*Free upgrade to customers that are in support as of this date. 

 

ClearID 2.5 New and Updated Features - Release Date: 09/14/2010 

- F7 Key added for launching ClearID (New) 

- Removing Alpha/Opacity Channels for accommodate PS CS5 change 

o Import Images as a Layer Stack now hashes & removes the Alpha Channel if present. 

o F8 Key function – Removes alpha channel 

- Improved real-time preview, faster launching and faster rendering speeds 

- Tab 1 - Use keyboard arrow keys to make adjustments in Video Field Alignment (New) 

- Tab 1 - Split Layer Stack into Fields function (New) 

- Tab 2 - ClearID Super-Resolution Functions (New) 

- Tab 3 - Interactive Deblur was split into two functions so they open with better default settings 

- Tab 4 - Interactive Channel Selector  with interactive preview and more channels (New) 

- Tab 7 - Verification Report Improved 

o The report is now HTML with enhanced formatting. 

o Reports Photoshop version and ClearID version information. 

o Thumbnail image is now displayed in the verification report. 

o Expand and collapse buttons allowing you to see the detail level you want. 

 

Video Overview of New Features 
 

       www.oceansystems.com/forensic/forensic-Photoshop-Plugins/ 

To see our other product and workflow videos in our video library, go to  
www.oceansystems.com/support/video_library.php 

http://www.oceansystems.com/forensic/forensic-Photoshop-Plugins/
http://www.oceansystems.com/support/video_library.php
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Reference the new ClearID User Manual for more details on all these features after reviewing 
them here. 

 
F7 Key added for launching ClearID 

Prior versions of ClearID used the F10 hot key to bring up the Clear ID workflow interface.  Due to 
changes in Photoshop CS5, we migrated to the F7 key for more consistent performance.  F10 will 
continue to work with this version of ClearID 2.5, however in testing we experienced intermittent delays 
with the interface appearing after F10 was selected. 

 
Testers reported having to “click” on the Photoshop interface after F10 was pressed to open the 
ClearID interface and intermittent delays with the workflow interface opening. 

 
You can also launch ClearID from PS Filters Menu > ClearID Workflow or PS Files > Scripts > ClearID 
Workflow 

 
Removing Alpha/Opacity Channels 

Alpha/opacity channels are treated differently in CS5. Images with an alpha channel now display a 
“checkered” pattern with no visual information. Additionally, programs like Windows Picture viewer 
have issues displaying these images. 

 
Import Images as a Layer Stack removes the Alpha Channel if present now hashes 

This tool is located under the main Photoshop menu:  File >Scripts>ClearID> Import Images as 
Layers.  This is similar to importing images from the Adobe Bridge: Tools>Photoshop>Load Files 
into Photoshop Layers, only the ClearID function will hash the image file layers on import and 
remove the Alpha/Opacity channel if it is present. 

 
If you are using TIFF images from DVR dCoder v2.5.2 or later, this should not be an issue.  But if 
you are using TIFF images created by earlier versions or by other programs, importing images from 
the ClearID> Import Images as a Layer Stack is an extra safeguard in your workflow process. 

 
F8 Key function – Removes Alpha Channel 

If you imported images directly from Adobe Bridge instead of using the ClearID> Import Images as a 
Layer Stack, you can remove the Alpha Channel on an image or images by using the newly 
assigned ClearID F8 key. 

 
Regardless of which import method you use, your images will get a final hash when you run the 
verification report. 

 
New improved real-time preview, faster launching and faster rendering speeds 

- Lens and Motion De-Blur, Ultimate Sharpener, Pattern Remover, Frequency Filters 
 

While using any of these filters, open an image and moves the sliders. You should get real-time 
updates as you slide them. This is a vast performance increase over ClearID v2.0.  Additionally, on 
internal testing, we charted the launching of these plug-ins at up to 40% faster and the rendering 
speeds up to 30% faster. 
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New Use Keyboard Arrow Keys to Make Adjustments in Video Field Alignment 

Hold down the CTRL key along with the up, down, left, or right arrow keys to shift the fields. 
 

Split Layer Stack into Fields 

If you have imported your images as layers that have two fields, you can now split image(s) into two 
separate layers so you have a separate layer for each field. 

 
 
 
 
 
 
 
 
 
New 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Old 
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ClearID Super-Resolution Functions 

We added a heading called ClearID Super-Resolution Functions. There is detailed information on this 
process in the user manual. 

 

- Reduce Image Size (pIS) name changed to Adjust Image Size (pIS) and moved under super- 
resolution functions. 
 

- Align Layers and Average (new) - Open two or more consecutive images and align them to a 
target, then average to view more details. 
 

o Hot Keys - CTRL Tab - Next Image, CTRL + SHFT + Tab Previous Image,  
CTRL + arrow keys nudge images and CTRL + mouse to move large distances. 
 

- Average Layer Stack - Allows you to frame average a layer stack that doesn’t need to be 
aligned first. 

 
 
 
 
 
 
 
 
 
 

New 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Old 
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Interactive Deblur has been split into two functions 

This allowed us to apply better default settings so each opens in a mode that provides better results. 
 

- Interactive Lens DeBlur (ID) 
- Interactive Motion DeBlur (ID) 

 
 
 
 
 
 
 
 
 
 
New 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Old 
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New Interactive Channel Selector (ICS) 

This is much improved over the old process. Now you view more color channels and toggle between 
them and apply them all in one place. 

 

- Hot Keys - Key letters (R, G, B, Y, etc. plus the `, 1, 2, 3, 4, etc.) and the F1, F2, F3, etc. Space 

Bar toggles between the last two images viewed. 
 
 
 
 
 
 
 
 
 

 
New 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Old 
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Verification Report Improved 

- The report is now HTML with enhanced formatting. 
- Reports Photoshop version and ClearID version information. 
- Thumbnail image is now displayed in the verification report. 
- Expand and collapse buttons allowing you to see the detail level you want. 

 
Verification Report - Images that were imported via the ClearID - Import Images as Layer Stack   
function located in Photoshop > File > Scripts. As such, the images have a hash in the layer name 
and a full SHA-1 hash value for each. To learn more about this function, reference the CID training 
manual. 
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Verification Report - Images sent directly from Adobe Bridge. 
If you send images directly from Bridge, they will not have the hash in the layer name since they are not 
hashed on import, but they will get hashed when you create the verification report. 
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Installing ClearID v2.5 

 
Computer Requirements 

 Win XP(32/64bit), Vista(32/64bit), Win7 (32/64bit) 

 Photoshop CS4 and CS5 in (32-bit) only — we recommend you allocate 50% RAM to 
Photoshop 

 Min Screen 1024x768 
 

Internet Browser Note - Firefox users will need to have it open before clicking the integrated help. 

 
This version of ClearID 2.5 unlocks “per user” and not “per machine”. A new unlock code will be 
required. (This will effect multiple login users…using the same computer) Contact Oceans Systems 
Support if assistance is required. Until the program is unlocked, it will run in a 30 day trial. 

 
You can only have one version of ClearID installed on your system at a time 

The ClearID v2.5 installer auto-checks for existing ClearID installations on your systems. If one is 
found, it will prompt you asking if you would like to remove it before you proceed with your new 
installation. 

 
Changing between ClearID v2.5 and previous versions. 

If you would like to revert back to an older version of ClearID, you should remove any previous 
installations before proceeding. 

 
ClearID v2.5 and ClearID v2.0.2 installers will automatically check for any previous installations and 
prompt you before it un-installs them. If you have ClearID v2.0 or v2.0.1, go to the download page and 
upgrade to v2.0.2 since it is a free upgrade and it includes this auto-checking installer. If you choose 
not to get this free upgrade, you will need to uninstall the existing ClearID manually via the add/remove 
programs function in windows before installing ClearID v2.0 or v2.0.1. 

 
If you don’t have the ClearID v2.0.2.exe installation handy and you need to install it, you can look on 
your system under C:Oceanystems/ClearID. This Ocean Systems folder is where we store the .exe 
files for the programs that have been installed on your system. This allows people to back rev if they 
need to recreate old work in the version that it was created in. 

 
 

TIP - Make sure your Photoshop and Bridge versions match when sending images to Photoshop from 

Bridge using the Bridge tool for sending images to Photoshop as layers. 

 

If you have two versions of Photoshop installed such as CS4 and CS5 you should match up the 
versions for Photoshop and Bridge. For Example - If using Bridge CS4 you should be using Photoshop 
CS4. 
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Installing ClearID v2.5 Actions 

1. Launch Photoshop 

2. In Photoshop, select “Window” 

3. Select “Actions” or Alt+F9 - This will open the Actions interface 

4. Delete your old ClearID Actions - Example “OS ClearID (r) CS4” 

5. Drag the folder into the trash located at the bottom right hand corner of the Actions interface. 

6. In the Actions interface, click the upper right corner to expand the menu, and then select the 
new “OS ClearID (r) 2.5” actions. (Figure 2) 

 

Changing between ClearID v2.5 and ClearID v2.0 
Don’t forget to load the matching Photoshop “actions” files if you are switching between versions. 
Delete your old actions and load the matching actions for the version of ClearID you are using. Do not 
leave two different actions loaded at once as they can cause conflicts. 

 

 
Step 4 
 
 

 
Step 6 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

 

 

Step 1 Step 2 

Step 3 

(Figure 1) 

Step 4 

 

Step 6 

 

Step 5 

 (Figure 2) 
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