ClearID Filters can now be recorded as PS Actions.
What are Photoshop Actions?
Photoshop Actions allow you to record processes or a series of processes so you can be repeated later.
This is how ClearID Workflow Interface is launched using the F7 key.
How did previous versions of ClD utilize PS Actions?
Previous versions of ClearID used the Photoshop Actions to do the following Functions:

Where are the ClD PS Actions loaded?
The Actions get loaded into the Photoshop Actions Panel accessible from PS > Windows Menu > Actions
When loaded, they displayed in the Actions Panel shown below.

What’s new in ClD Regarding Actions?
1) Existing Action names got updated - The existing CID PS Actions names have been updated to better
reflect what they do.
2) Record your own Actions – CID now provides the ability for you to create your own ClearID PS Actions
using the ClearID scripts. This allows a CID filters or combination of filters to get applied as a single Action
that created a new PS layers with a hash values, etc. The Actions can also be used to Batch Process image
or if you have a favorite filter you like to use like Pattern Remover or the Verification Report function, you
can now create an action to call those up click a click of a button or by mapping them to an F-Key.
Action Example 1: Interactive Channel Selector with Green Channel and then Pattern Remover.
Action Example 2: Call up the Verification Report Generator mapped to F2

3) We also added two new Actions Sets – While implementing the new CID PS Actions feature, we provided
two new Actions sets.
#2 is an Actions Set showing an example of what you can do.
#3 is where you can record and store your own End User Actions.

Loading the CID New Actions Sets
1) First highlight your old ClearID Action Set from your previous installation.
2) Delete the older set by either dragging it to the trash can in the lower right corner or by highlighting the
set then clicking the trash can to delete them.
(If you don’t delete the old actions first, the newly loaded ones will not get their corresponding assigned
F-Keys, as those keys will already be allocated to the old action set)

3) Next select the new Actions one at a time to load them into the Actions Panel. Do this by clicking the
Actions Panel fly out menu in the upper right hand corner of the panel, then selecting each Action listed
below one at a time to load them.
1 - Ocean Systems ClearID 3-3 Base Set
2 - Ocean Systems ClearID 3-3 Processing Actions Set Example
3 - ClearID 3-3 End User Recorded Processing Actions Set

Using the ClD New Actions
1) Open a color image in PS. In this example we used “Dessert” from the Windows Library Pictures Samples
a. If you want the image hashed on import, use PS > Filters > ClearID Image Images (F6)
2) If the Actions Panel is not already open, open it. PS > Windows > Actions ( Alt +F9)
3) Scroll down the list to the new ClearID PS Actions. Within the #2 set, highlight DCT/JPEG Detector

4) With the Dessert image open, Click the play button located in the bottom of the controls panel
This will run the recorded DCT/JPEG Detector Action on the image you have open.
Below are the before and after results.

5) View the layer of the process applied from Photo Layer by clicking the PS Layers menu at the top of the
panel. If PS Layers is not open go to PS > Windows > Layers to display it.

6) To delete the results, highlight the layer and click the trash can.

Next we will walk you through creating your own recorded Action.

Recording Your Own CID PS Action

1) Highlight the “#3-ClearID End User Recorded Processing Set”, then click the “New Actions” icon
2) For test purposes, you can call it something like “Testing Creating CID Actions. You can edit the name
later if needed by double clicking on the name.
Note - Be careful regarding assigning Functions Keys as to not override a PS function you like to use. Don’t
worry about assigning an F-key you have already assigned to another PS Actions because PS will filter out
those options. To edit F-Key assignments, double click in the black area to the right of the Action Name.

3) Next, click the Record button in the above interface, then access ClearID Workflow from
Photoshop > Filters Menu

DO NOT USE THE ‘F7 KEY” TO LAUNCH CLEARID WHEN RECORDING ACTIONS
It you attempt to record actions using the F7 Key. If you do, the ClearID Workflow Interface will launch to the
filter you recorded, but that is as far as it will go. It will next proceed to apply the filter with the settings you
selected and move on to the next set in applying the recorded action.

4) Once you launched the ClearID Workflow interface from PS > Filters > ClearID Workflow,
select a filter, and click OK

5) Make your filter adjustments, then click OK
Below we are using “Red”, “Expand Contrast” and “False Color”

6) You can continue to repeat the above process and stack more filters, but for this example, click the stop
button to end the recording of this newly recorded action.

7) You should now see your new Action listed in the Actions Panel - “Test Creating CID Actions”
Clicking the arrow to the left of the name will expand the action to reveal what you recorded.

8) To test this recorded Action, return to the Layer Tab/Panel.
9) Highlight the layer, and hit the delete key or drag it into the trash. If not you will be processing the already
nd
processes image a 2 time.

10) Return to the Actions Tab/Panel.
a. Highlight your recorded action.
b. Click the play button to apply the Action.

11) If you want to assign an F-Key to the Action, double click to the right of the Action name to access that
window shown below. Choose an F-Key and click OK.

Archiving, Sharing, Moving and Loading Actions
Saving Actions
Actions are recorded within Actions Sets and those Action Sets can be exported as an .ATN file. This allows you to
create backups, share/move them to other systems, store them in a case folder, reload them, etc. Additionally,
saved Actions can also be used for batch processing multiple images which will be reviewed in a later section.
If you invest time creating Actions, it’s a good idea to archive them to a safe storage location.

How to save an .ATN Actions Set
1) Highlight the Action Set you want to Save/Export
2) Click the Actions Panel fly out menu and select “Save Actions …”
3) Browse to a Save To location where you want to save the .ATN file and click Save
Notes
- If you highlight an Action instead of an Actions Set, the “Save Actions” option will be grayed out.
- Once you choose a save to location, this will be the place that opens the next time you save or load an action.
Loading Actions
1) From the Actions Panel shown above, click load Actions and browse to where you saved the .ATN file.
2) Select the Action you want to load then click the load button.

Workflows for Creating Actions
Simple Actions
If you are creating a simple Action such as mapping a single function such as the Verification Report to an F-Key or
you know you want an Action that calls the Channel Selector with the green channel, you can create a new Action
on the fly.
Creating Compound Actions for Batch Processing
If you are creating a multi-step Action and are not sure of all the filters and settings you want included, then here is
one easy to follow workflow.
1) Process the target image from the series of images.
2) Create a Verification Report from CID Tab 7. This will list all the filters used along with their settings.
3) With that in hand, create your new Action using the Verification Report your recipe.
For step-by-step instructions on creating Actions, reference Recording Your Own CID PS Action

Batch Processing
To batch process using a PS Actions, the Action Set must first be loaded in the Actions Panel.
There are two ways to access the image processor to batch process images (From Photoshop or From Bridge)
How are they different?
The difference between the two is workflow related as to how you select, organize and view the images before
and after processing. Which you use is user preference.
-

Using Photoshop – Using Photoshop, you will organize your images into folders first using Windows
Explorer then process that entire folder by accessing the Image Processor through PS. Then view the
results through Windows Explorer. Using this workflow you cannot select a sub set of images in a folder
to process. Since you are most likely going to process a folder of images for organizational reasons, this is
an easy to follow option for those not familiar with Bridge.

-

Using Bridge – Using Bridge you can view your images, select a sub set of images from a folder or organize
them into new folder if you decide on that workflow. Then from Bridge you can access the image
processor. Once completed you can view the results from within Bridge.

Depending on how you access the Image Processor, you get different options displayed at the top of the Image
Processor in Section 1. The rest of the interface is the same.
From Photoshop

From Bridge

Using this option you first organized your images
into a folder through Windows Explorer then
launched the Image Processor from

Using this option you have already selected your
images from Bridge then launched the Image
Processor from

PS File Menu > Scripts > Image Processor

Bridge > Tools > Photoshop > Image Processor

Batch Processing from Photoshop
1) From Windows Explorer, browse to the folder with the images you want to process to review your source
media before processing.

2) If you do not want to process the entire folder, create a sub folder and copy the images you want to
process into that new folder.
3) From Photoshop, go to the File Menu > Scripts > Image Processor

4) Select the folder of images you want to process.
5) Save To Location - By selecting “Save in Same Location”
and “Save as TIFF", your processed images will get stored in
a TIFF sub folder that gets created automatically.
Or you can use “Select Folder” to browse to a new location
to store the processed images. Again, with “Save as TIFF”
selected, a TIFF sub folder will get created in that new
folder location.

6) Check the box next to “Run Action” located in section 4. Then select the Action Set that contains the
Action you want to use.
Note – Action Sets must first be loaded in the PS Actions Panel to make them accessible from the Image
Processor. If you don’t see the Action Set you want, return to the Actions Panel and load the Actions Set
you want to use. Then return to the Image Processor and select it.

7) You can change Action Sets with the drop down arrow then select Actions within that set.
(Note – Before proceeding to step 6, if you have dual monitors and want to continue to do other work in
another program, drag that program to the second monitor as the batch process will tie up the window its
displayed on while processing)
8) Once you have the settings you want, click the “Run” button in the upper right corner and the images will
get processed.
Below is the end result from the above batch process where “Save in Same Location” was selected with the Save as
TIFF options.
You should now have a new folder names TIFF that holds your processed images.

Batch Processing from Bridge
1) Launch Adobe Bridge. In PS CC you can do this from PS > File Menu > Browse in Bridge.
2) In Bridge, browse to your images and select the ones you want to process.
a.
b.

Shift click first and last to select a subset of images
Control + A to select all

Note - To batch process using specific PS Action, the Action Set must be loaded in the Actions Panel first so they
can be selected the Actions Set and Action in the Image Processor.

3) Access the PS Image Processor from Tools > Photoshop > Image Processor

Check the box next to “Run Action” located in section 4. Then select the Action Set that contains the Action you
want to use.

Note – Action Sets must first be loaded in the PS Actions Panel to make them accessible from the Image
Processor. If you don’t see the Action Set you want, return to the Actions Panel and load the Actions Set
you want to use. Then return to the Image Processor and select it.
4) You can change Action Sets with the drop down arrow then select Actions within that set.
(Note – Before proceeding to step 6, if you have dual monitors and want to continue to do other work in
another program, drag that program to the second monitor as the batch process will tie up the window its
displayed on while processing)
5) Once you have the settings you want, click the “Run” button in the upper right corner and the images will
get processed.
Below is the end result from the above batch process where “Save in Same Location” was selected with the TIFF
options.
You should now have a new folder names TIFF that holds you processed images.

